Kentico Xperience 13 documentation and ASP.NET Core

Most documentation about running Xperience applications under ASP.NET Core can be found in a dedicated section: Developing Xperience applications using ASP.NET Core. The rest of the documentation still applies, but some code samples and scenarios might need slight modifications for Core projects.

All major differences between the MVC 5 and Core platforms are summarized in Migrating to ASP.NET Core.

×

Customizing on-line stores

The Xperience E-commerce Solution allows you to extend the scope of the available features and customize the default functionality. You can achieve this by integrating tools developed by third parties, such as applications, utilities, services, website templates, etc. You can also enhance or adjust the system by adding your own custom code implementations or even entire modules and applications.

Integrating custom functionality

The system provides an extensive customization API that allows you to adjust, extend, personalize or override the default e-commerce functionality. For more detailed information, see E-commerce customization model and the other sub-pages in this chapter.

The system also provides tools for integrating with external applications, for example using the built-in integration bus or REST service.

You can also set up Google Analytics Enhanced Ecommerce tracking on your website, which allows you to measure and analyze shopping activity (product impressions, purchases, etc.).

Integrating functionality from the Kentico Marketplace

The Kentico Marketplace, the official Kentico community feature sharing portal, offers a range of third-party features recommended for use with Xperience.

Typical examples of E-commerce add-ons are payment gateways, shipping providers, connectors for tax calculation services, etc. See the Kentico Marketplace.

Note: Not all marketplace add-ons are available for all versions of Xperience. Before you install an add-on to your production site, check the add-on description and make sure it is compatible with your version.


Was this page helpful?